Jump to content

A77ii : not able to read any memory stick or SD card


Recommended Posts

Recently my A77ii keeps saying it cannot read any memory card and basically camera is inoperable as I cannot access menu nor take pictures. Any suggestions on how to resolve this will be appreciated.

Link to post
Share on other sites

Are you sure the memory cards are good.  They could have been damaged in some way you are unaware of, such as being exposed to magnetization.

Do you have another device (camera, printer, computer, etc.) that can determine if the cards are OK?

Does your manual say your camera can operate (turn ON) without a memory card?

Does your camera have only one slot?

Edited by XKAES
Link to post
Share on other sites

I would try to use very small amount of contact spray to clean both sides, the sdcard contacts and those contacts inside camera as well, again, very small amount of it and not to use any cleaning fluid which may damage plastic or glass. 

 

That would be enough for checking if the issue is related to the contacts. Next step is complicated, wires and boards inside camera, which is requiring much better experience, would not be suggested to be done by anybody who is not skilled enough for that.

Link to post
Share on other sites

Yes I have tried multiple cards and same result. I have tried same cards in my MacBook and they work.

I have tried to clean the card contacts, but the camera is a different ball game as the slot is too slim for me to get to it.

camera has just 1 slot

camera does turn on without a card in it and in it. However, without a card I cannot take pictures and when card is in it the menu is inoperable as it is covered by the error message.

Link to post
Share on other sites

Few more, related suggestions.

Seems that the A77ii may have that issue sometimes.

You can find videos about SDCard slot cleaning easily, using contacts cleaning fluid.

Also, it may be good to try air blower to be sure that there is nothing inside the slot which may make issues.

And, related to the starting camera process, seems that the A77ii itself should or may try repairing the (broken?) SDCard at the time when the camera is turned on, so it may be suggested to check some off / on steps (turning camera off then on while pressing some combination of buttons, also, battery remove / insert during that), being mentioned at few other sites. Of course, any step to be done carefully.

The worst is if wires inside camera, or any processing hardware part is / are broken; anyway, there are few of those procedures to be checked if helpful; then; last option; bring the camera to Sony service.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...