Jump to content

My LCD screen stopped working shortly after strange horizontal lines began appearing on the bottom on the screen. Need help!


Recommended Posts

Advertisement (gone after registration)

Recently my LCD screen stopped working. Everything I’ve researched addresses the screen going black but my problem is a little bit different and I can’t find anything that addresses it.

 It started as a faint reddish-orange thin horizontal line right above the camera settings extending the entire width of the bottom of the screen. It was almost like a ghosting effect over the text. Over about the next hour or so the lines gradually multiplied upward in a variety of brighter colors until it was 1/2 way up the screen. Shortly after it fizzled the rest of the way up very quickly and turned dark. It didn’t turn completely black or even a solid just dark gray with thin vertical lines all the way across. 

I’ve attached pictures of the screen when the problem got bad. It’s not a great pic but it was dark and foggy and I was in the middle of a huge field in the middle of nowhere. 

The camera itself still functions properly but I can’t switch feed to the viewfinder because I had set it to monitor only. I hooked up an external LCD and tried to change it that way but the option was grayed out.

I have a theory on what could have caused the problem. I was doing some running around and quick on my feet stuff so I had worked up quite a sweat. I had my screen tilted up and on a few or more occasions my sweat dripped from my hat onto the screen several times.  I’m not talking about a mist either. I was sweating hard. Of course I wiped it off immediately but only the front. I was in a dark environment and trying to keep pace with my subjects. And honestly didn’t think it was anything to worry about.

In looking at the back of the LCD screen I noticed that it appears to be somewhat open in terms of the housing and If that’s the case my sweat could’ve easily rolled around the back into the grove that’s directly on the bottom on the back of the screen.

Im almost positive replacing the screen is the answer but before I dive into the repair I want to get some opinions

I did buy this camera refurbished from Amazon about 6 months ago and also purchased a warranty with Asurion but I’m not paying deductibles and waiting forever to solve this over a $50 part I can replace myself. If it was serious damage then obviously I’d have no choice.

I would greatly appreciate any feedback! 

 

113C2473-FD38-4A47-BA5D-4E0D77332D94.jpeg

4119AAEC-F314-45A7-8149-26CDF8008B35.jpeg

Link to post
Share on other sites

Welcome and good luck :)

You seem settled to it being a hardware problem and probably permanent. Good luck too, with the part only costing $50! But I don't have the experience. Youtube probably has the disassembly/reassembly covered.

(If it's hunchtime, I'd agree about the moisture. I've heard of over-wet computer-monitor cleaning causing this kind of failure. On the other hand... any chance the ribbon cable simply came loose?)

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Posts

    • Does anyone else have issues with a jittery image on their A7SIII EVF when in video mode, recording in 4K S-I 10bit. It only occurs with this codec and is totally smooth with no issues in all other codecs. Wondering if this is just my unit or a common problem?
    • On my Mac, I right click on a photo and select "Info".  A popup shows me aperture, shutter speed, but not ISO.  Does the A7C record ISO  If so, how do I access it on my Mac?  Is there an app?  Thanks.
    • Hello everyone. So I have really wanted to grab a timelapse of my resin printer.  Uncle Jessy from youtube has come out with a pretty cool cable that is a photoresistor that can take your shots as the leds are firing inside your printer. Resinlapse Cable Resulting in perfectly timed prints as it raises out of the vat. My question though. The cable he made is for Canon cameras. So I purchased an adapter that should work in theory. See below. Lanc cable But I got it all together today and it does not work. Unless I am missing something. Is there a setting I need to turn on to get the Multipass port to look at what is plugged in? I don't even know how to troubleshoot which cable is the one that is not working ,as I do not have a Canon camera on hand. Did I do something/get the wrong gear? Camera: Sony a6400 Lens: Sony SEL90M28G
    • First, there is a typo in my original response.  I wrote "The focal length of a lens does not change when the film/sensor size changes -- but either does the angle of view or the field of view of the lens." That should be "The focal length of a lens does not change when the film/sensor size changes -- but neither does the angle of view or the field of view of the lens." There is a description and a visual graphic of the differences of what we are discussing on my website: The World's Most Complete Fujinon Large Format Lens List  
    • 🤔😄 (sorry for that) Forgive me, but English is not my native language, so maybe I'm misunderstanding you or not understanding you properly. I might need a thorougher explanation. I think I understand what you are trying to convey, but are you saying that a "picture" has an angle?? How come? Anyway, I hope that with everything that has been said and explained, NK Creative's question might have been answered. Has it? It would be nice to have his feedback.
  • Topics

×
×
  • Create New...