Jump to content

- - - - -

Sony a37 "strange" autofocus behavour

a37 autofocus flash

  • Please log in to reply
No replies to this topic

#1 pykami



  • Members
  • Pip
  • 1 posts

Posted 11 March 2018 - 08:56 PM

Advertisement (Gone after free registration)


this might be a more unusual question, but I definately do not feel up to solving this on my own anymore.


I have a Sony a37 camera which has, as stated in the topic, developed a rather strange AF problem.

When the camera is switched on and set to P, A, S, M, or the other two automatic modes and you try to take a picture, the AF does not work, nothing happens at all.

However, when you switch from AF to MF, take a picture and then switch back to AF, it works just fine.


When in "Flash off" mode the AF works just fine even though sometimes the flash pops up without being actually used.

When a flash is added to to hotshoe, everything works just fine.


I have tried resetting the camera, leaving the battery out for a longer time, nothing has worked so far. The Firmware Version is 1.04 so I can not update it again.


I have tested it with a lot of different lenses, Sony SAL 1650, SAM 1855, Tamrondi2 16-270, very cheap Tamron 18-200, Minolta 28-135, Big Beercan, different Minolta, Sigma and Sony primes etc.


If anyone has an Idea on how I could try to solve this problem I would be very grateful to hear it, if not then hopefully it was entertainning hearing about another strange problem :P


Thanky in advance, Michael.

Also tagged with one or more of these keywords: a37, autofocus, flash

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


New Members Welcome!

Not yet registered? Really?

Registration is free and takes only a few minutes.

After the free registration you can discuss with members from all over the world, put questions and present your images.

We are looking forward to you!

Admin Andreas und Sony Alpha Forum Team

Register now! X