Jump to content



Recommended Posts

I have a Metabones EF-E-BT4 adapter (canon lens to sony e body mark VI)

I bought it second hand.  It's in really good condition, but the firmware was never updated.  It's on V45.

I've downloaded the software to update it from metabones, followed the instructions by plugging in the adapter after the program opens, but nothing happens.

I've tried different cables, and even a different computer.  Same thing.

I'm on mac running mojave.  The current metabones updater is to put V63 on. 

Anyone have any ideas?

Link to post
Share on other sites

  • 4 weeks later...
On 1/17/2020 at 11:51 AM, MIkepeppers said:

I've ended up solving my own problem.  And today I learned that those usb charger cables that are everywhere come in 2 different varieties.  Charging and Data Transfer.  I was of course using the wrong one.

Problem solved!

hey yeah I realized that  awhile back too, its probably cheaper to manufacture dataless cables

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...