Jump to content

Feelworld F570 goes black upon record button on A7RIII


Recommended Posts


Tried to search the www and here for this but couldn't really find any info regarding the 3 series A7 bodies.

Problem is the following: when I hit the record button on my A7RIII in 4k/100M mode, the Feelworld F570 external monitor via HDMI goes black. 4k HDMI output is set to 24fps as the F570 doesn't handle 60fps. I can see the HDMI output on the monitor until hitting record and can also play back 4k files and see them on the F570 but have no live picture during 4k recording.

1080p is fine at all fps levels.

I have tried:
- setting HDMI resolution to auto, 2160/1080p, 1080p and 1080i
- using different HDMI cables with different data transfer ratings
- 30p and 24p 60M modes
- changing gamma assist mode or turning it off
- going through the menu of the A7R3
- going through the menu of the F570 multiple times
with no success.

Sony manual claims the following by HDMI settings:
"* Images will not appear on the monitor of the camera if you record movies while the camera is connected to and HDMI device with file format set to XAVC S 4K" but actually the monitor of the camera displays what I'm recording HDMI doesn't.

I'm totally out of options here, anyone have any ideas?

Thanks in advance!

Link to post
Share on other sites

  • 4 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...