Jump to content
Sign in to follow this  

Sony a37 "strange" autofocus behavour

Recommended Posts


this might be a more unusual question, but I definately do not feel up to solving this on my own anymore.


I have a Sony a37 camera which has, as stated in the topic, developed a rather strange AF problem.

When the camera is switched on and set to P, A, S, M, or the other two automatic modes and you try to take a picture, the AF does not work, nothing happens at all.

However, when you switch from AF to MF, take a picture and then switch back to AF, it works just fine.


When in "Flash off" mode the AF works just fine even though sometimes the flash pops up without being actually used.

When a flash is added to to hotshoe, everything works just fine.


I have tried resetting the camera, leaving the battery out for a longer time, nothing has worked so far. The Firmware Version is 1.04 so I can not update it again.


I have tested it with a lot of different lenses, Sony SAL 1650, SAM 1855, Tamron  di2 16-270, very cheap Tamron 18-200, Minolta 28-135, Big Beercan, different Minolta, Sigma and Sony primes etc.


If anyone has an Idea on how I could try to solve this problem I would be very grateful to hear it, if not then hopefully it was entertainning hearing about another strange problem :P


Thanky in advance, Michael.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By foetusmachine
      Hi All,

      I posted this question in an underwater photography forum, as that's my focus, but didn't have much success in getting responses. Maybe it's too technical a question, but I thought i'd try again in different forums.

      I'm working to understand how my a6000 works in detail with the aim of (possibly) making my own LED TTL converter. At the moment I use the a6000 with its internal flash to trigger a set of underwater Sea & Sea YS-D2 strobes using my optical cables. I either use the strobes in manual or TTL mode. The TTL is reasonable, but not always perfect.

      I wanted to understand how the a6000 TTL system works, so I connected a little oscilloscope to my hotshoe x-sync pin and used the other channel of the oscilloscope with a photodiode to monitor the flash.

      See attached 2 screen grabs for two flash types - Fill Flash, Rear Sync. I also did a slow sync, but it's result was remarkably similar.

      I wasn't able, in any case, either Manual, Aperture priority or full automatic, to witness any pre-flash whatsoever from the camera's internal flash.

      Does the a6000 meter TTL during the exposure? Am I missing something here.

      Welcome any insights, comments or suggestions to be able to run another oscilloscope test.



    • By rlinton
      What is the best value off camera flash for real estate photography?
    • By ManuelBeck
      this is my first post on this forum and English isnt my first language so please be gentle
      I made the switch from Nikon to Sony. One of the key features that attracted me towards Sony was the EVF and the resulting "What you see is what you get" in the live view.
      My gear:
      A7iii + Godox V860ii S or Xpro S both as masters. (Several GM and G lenses)
      My problem:
      As soon as I attach and turn on my flash unit or trigger, the camera overrides the "setting effects ON". That means I no longer get a real representation of the ambient exposure but a "simulated" exposure in the viewfinder. I get that they do that in order to be able to still see something when using strobes in very dark environments, but I am wedding photographer and mostly use my Flash as a fill or for creative effects. I would love to still be able to see just the ambient exposure so that I can expose for that and add the fill flash. 
      I`ve read on several sites that to overcome that "problem" some people use the Shot Result Preview mapped to a custom button. That would be a nice workaround but in my case IN DOESNT WORK. All it changes is a tiny bit of exposure if I really increase F-stop numbers. But when I compare the resulting exposure using this function to the exposure resulting in turning the flash off (or with the picture taken), it doesnt match at all. Also, Shutterspeed and ISO changes dont influence the exposure using Shot Result Preview. 
      My question:
      Does anyone experience the same problem with their A7iii?
      Is there a setting I have missed which interferes maybe?
      Is there a known issue or bug with the A7iii?