Jump to content
SLai

Corrupted MTS files

Recommended Posts

I have a bunch of MTS video files which seem to be corrupted (i.e. cant open in VLC or media player, or on my SLT-A58 itself). The filesizes seem large enough, so I guess/hope all the information must be there. They are videos of my wedding ceremony, and I really need them. Any advise on where to start looking for a solution is very welcome. Paid solutions welcome as well, as long as it gets the job done, these videos are extremely important to me.

Share this post


Link to post
Share on other sites

Hi, 

 

if you're on a Mac you can right click the MTS files and choose something along the lines of "show package content". MTS is just a container (a bit like a folder), inside you will find the "normal" video files that you can then drag and drop wherever you prefer.

Share this post


Link to post
Share on other sites

Hello, maybe you can try the following methods, hope those way can help you:

1. Upgrade the video editing app
updating the app and removing the cache files can fix MTS video playing problem.
2. Update your PC drivers
It may be possible your PC video drivers are not updated, which may have been causing the MTS videos stuttering issue. Update your PC drivers by performing Windows updates.

Or you can apply a MTS video recovery tool, I recommend the Bitwar Recovery tool, I think you can have  a  try.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By HBI
      Hi - I have recently bought a Sony a7ii mirrorless camera and filmed with it in rush without looking diligently into everything. I didn't realise I had to use the PlayMemories Home to transfer the footage elsewhere. I did the traditional method of copying and pasting the entire folder from my SD card into an external drive. I have shot all my footage with the XAVC S format. And for a while, I couldn't figure out how to get access to the MTS files, but when I solved it, some folders were empty (while viewing on the hard drive). The folder size of the MTS files is in KB instead of GB.    Now, I only have access to all the MP4 files (low resolution) and unable to access the MTS files when I follow this pathway AVCHD > BDMV > STREAM > MTS. According, to a Sony customer support specialist I spoke to, not using the app could result in damaged or unplayable files. The SD card has long been formatted, so no way of going back to this specific step.    I'm wondering if anyone else had had this issue and if there's any advice anyone can offer. It's really distressing. 
    • By ph_LDA
      I know I'm not the only one. I know that this forum is full of sony lover, I'm one too, so I put my hands ahead and beg you not to defend the a6300 at any cost. 
      this is serious. I've had many cameras, which I treated very bad, being in my youth days a photographer of disasters like earthquakes and similar.
      this a6300 is my first mirrorless, my first sony, and the first camera I've ever treated as a fragile child, always keeping it clean and warm and safe. It also is the first camera to ever fail me.
      It happens that all of a sudden it stopped responding to any input but shooting pictures. at first solely every once and then, then it got worst and worst till the day it could only shoot pictures, not opening the menu, not changing aperture or shutter speed, no anything. I figured it out: it is the shutter button: for some reasons it remains "half pressed".  I searched the web and found out that it is a COMMON ISSUE, which is not good at all. I want to add to this that that button seemed a little awkward to me since my first uses of the camera. I assumed it was my imagination at that time, and maybe it was. I don't want to point out any crafting failures or so, but
       
      - why the hell does it happen?
      - how do I fix it?
       
      I love my camera and don't want to change it - nor can I afford to, now that I think of it : )
       
      with love, yours
      @ph_LDA
    • By marcialsommer
      Hi Guys, 
       
      I have recently bought a6300 and have upgraded to the LR Classic subscription plan, because my LR5 couldn't read the ARW files. 
      Now a really weird problem appeared. I have imported about 200 images from a recent trip, at first all was good until a few days after my backup software Carbon Copy Cloner detected dozens of read errors. 
       
      After that this particular folder in LR was crippled. The previews didn't load anymore (sometimes after over a minute the sharp picture would appear), all develop sliders were greyed out, and when i try to export them as jepg's LR crashes. Many images now have a black exclamation saying that "LR has encountered problems reading this photo and that you will not be able to make adjustments".
       
      Opening the files in PS it won't work, mac's preview won't load, and trashing a single file takes up to two minutes (I have to do this for dozens of files now and will loose the images). 
      In the past i sometimes had similar issues with single images like that (a black exclamation mark over the photo and an 'error working with this photo'). 
       
      Carbon Copy Cloner suggests that 'Bad sectors are "spared out" — permanently marked as unusable — only when the files on those sectors are deleted.' - do you think it's possible CCC had read errors and then deleted the files? They still appear in the finder though. CCC also suggests this issue may be due to a bad harddrive (these images are all on a 2 TB external Seagate drive. 
       
      This is all very strange, I've worked with LR for years and never had this issue. I'm working on a Macbook Pro 2016 running 10.13.1 and LR is also fully updated (7.0.1)
       
      Before i spend time trashing them all I wonder if there are any options to recover my files. I'm having trouble finding people with similar issues though. 
       
      Any help would be MASSIVELY appreciated, especially as a big trip is coming up and I don't want to deal with this on the road. I'll try using a different drive in the future. 
       
      Cheers, 
       
      Marcial
×
×
  • Create New...