Jump to content
Ryan5

this operation or setting not available as follows eye tracking

Recommended Posts

Hi There,

 

I'm a noob here and have only owned the A7R for 2 days so please be gentle if I've already done something wrong. I did search for this but couldn't find any reference. I have been following the Gary Fong tutorials and when I get to the Eye focus tracking, I custom set the AEL button but when I hit that button whilst focused on a subject I get the following error message. This operation or setting not available as follows eye tracking. I'm using the Sony 70-200 OSS lens and I'm completely stumped as to what I'm doing wrong.

 

Any assistance would be greatly appreciated.

 

Thanks

Ryan

Share this post


Link to post
Share on other sites

 

Perhaps I am missing something, but I use Eye Focus Tracking (in AF-C mode and Wide focus area) usually with Face Detect off. It's a separate function as far as I know but I could be mistaken. Eye AF reverts to Face Detect if it can't find an eye.

 

You have to put Eye AF on one of the Custom Buttons (I use the AEL Button) and press and hold this button for it to work. Then you press the shutter button to take the exposure.

Share this post


Link to post
Share on other sites

I also found this which might help you.

 

"Turn off face detection and set the camera to AF-C and Wide Area focus (not lock-on). Press and hold down the button assigned to Eye AF. Don't release the button.

 

With an eye somewhere in the central region of the EVF, you will see a tiny green square that locates itself over the eye. This is a PDAF point that has locked onto the eye.

 

When you swing the camera, the green square will keep on the eye. I used a photo magazine with a face on the front page as the target, It works every time."

 

Note I think eye detect requires using Phase Detect which requires FE lens , not a adapted lens, and Phase detect only works at f stops f8 or wider ,

 

Hope that helps.

Share this post


Link to post
Share on other sites

Thanks for your replies guys. I was trying to do this in stills mode. I also tried to set the custom button as described above but it still didn't work. When I get home from work tonight I'll try your instructions ADWD, thanks for your help. I'll post the results of my efforts. I feel so clumpy going from Canon and Nikon to Sony... very confusing on various levels.

 

Thanks again

Share this post


Link to post
Share on other sites

Ok so when I got a chance to try out your suggestions I found that this error message occurs the second I press the AEL button that I've custom set. Subsequently I don't get any further into your instructions because of that. I've made sure my settings that you've outlined are the same but still no luck. Perhaps I'm not assigning the custom button correctly?

Share this post


Link to post
Share on other sites

Ryan, let's try to sort this out for you, so can we start with the the basics.

Can you please give us the following:-

Body model

Lens make and model,

Meter settings

Focus settings

Drive settings

And so on let's have them all,

Some where in there will be the problem and then we can help

Alistair

Share this post


Link to post
Share on other sites

Thanks for your help Alistair it's greatly appreciated, as somebody that has been shooting semi-pro for some years I feel like a total noob again and it ain't fun ;)

 

Body model - A7R Mi - ILCE-7R

Lens - Sony FE 4/70-200 G OSS

Meter settings - Multi

Focus settings - DMF

Drive settings - Single shooting

Focus Are - Flexible Spot: M

D-Range Optimizer: Auto

 

let me know if I've missed something or need to provide more info.

 

thanks again mate

Share this post


Link to post
Share on other sites

Ok thanks, as soon as I get somebody to take some shots on i'll see if that makes a difference. I do recall having it set to continuous originally but for some reason I change that, perhaps because it wasn't working for me originally. Hopefully i'm wrong and this fixes the issue. Thanks again for your support.

Share this post


Link to post
Share on other sites

Ok I just tried it an all I get is the focus square around the subjects face, the area is moderately well lit but absolutely nothing happens in regards to eye tracking or eye identification.

Share this post


Link to post
Share on other sites

I'm back button focusing with the AF/MF button flipped to AEL and press it. I've also tried the shutter but neither of them track the eye. There could be a possibility that I didn't assign the button correctly as I did it while watching the Gary Fong video. I noticed his menu was quite different from my Sony so perhaps I didn't do it correctly.

Share this post


Link to post
Share on other sites

This button. When following Gary Fong he said that the lever needed to be switched down to the AEL position though where in this photo it is up - either way it's the button not the lever that I've mapped

20sal5d.jpg

Share this post


Link to post
Share on other sites

Ryan,

As from factory, when the lever is down , the button locks the current exposure the camera or you have selected. When the lever is up , the button controls whatever the button is mapped to. Default being change between manual and auto focus.

Please try with the lever up, and if that still does not work, remap any other button to eye focus, make sure your focus mode is on continuous, face can be on or off, (I think better on) after that nothing matters. Use a photo , magazine cover any thing with a face with obvious eyes, make sure you are at f7 or wider best to try wide open if the light permits it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...