Jump to content

Recommended Posts

Advertisement (gone after registration)

Hi - does anyone know of an update on the diabolical file numbering system and camera identification on the Sony A7s mk 2?

 

This is a total, total pain in the butt for multi-camera video sessions. Compare this to the obvious simplicity of the Canon system - indeed, pretty much every other manufacturer - where files are consecutively numbered and each camera has a unique identifying prefix.

 

I moaned about this some while ago, and passed this message on to Sony.

 

Any news of a firmware update that may resolve this infuriating problem?

Link to post
Share on other sites

You can create folders on the memory card, 100MSDCF is the default one, but you can copy that and give it a new number, 110MSDCF. Then just select the one you want from the menus. After that, any reasonable PP software should be able to handle it with a bit of effort on your part.

 

Otherwise you have to keep waiting for the firmware update, last I heard was Photo Kino in September ...

Link to post
Share on other sites

Thanks for that, timde.  I have 4 cards, as I use the A7s2 to make long-form documentaries and sometimes have very busy days.

 

Sorry to be a bit thick, but are you suggesting I make a folder with a unique name on each of the cards; download the folders to a hard drive when they are full or a session has finished; delete the files from the folder on the card; empty the trash; then start again?

 

Is that it? Is it possible to delete the files but not the folder, or do I have to reinstate the folder for the next shoot?

 

At the moment I download the files; batch rename them; then format the card and start again. The problem with this is I am not well-organised enough to give each folder a sequential number so I don't have any chronological order.

 

Canon is sooooooo much simpler!

Link to post
Share on other sites

If you are on a Windows machine you could do some automatic actions when inserting a card to the card reader.

Here is the workflow that's works for me (you need a little bit of computer skills, very basic)

 

I use two freewares from http://www.uwe-sieber.de/usbdlm_e.html.
USB Driveletter Manager and EjectMedia.

For renamning the photos as well as movies I use another freeware, exiftool.
http://www.sno.phy.queensu.ca/~phil/exiftool/

First I make sure that the SD card slot on the Lexar Cardreader always will be mapped as K:
I use the USBDLM and have these settings in the ini file.
.......................................
[DriveLetters60]
;Lexar 5slot, SD card slot
DeviceId6=000000027677&1
Letter=K

[OnArrival]
Letter=K
open="U:\script\move_raw_2_import.cmd"
 ......................................
 First the mapping and then when a card is inserted, start a script
 
 So here is what I do in the script (it's an easy batch script)
 
:: Check for images on media and copy files from cardreader to folder on harddrive
IF NOT EXIST K:\DCIM\100MSDCF\NUL GOTO MOVIE
    copy /Y "K:\DCIM\100MSDCF\*.*" "C:\import"
:: Rename all files in import folder, here just jpg and raw
    u:\script\exiftool.exe -m "-FileName<DateTimeOriginal" -d "%%Y-%%m-%%dT%%H%%M%%S%%%%-c.%%%%le" c:\import

:MOVIE
:: Check for movies an media and copy files from cardreader to folder on harddrive
IF NOT EXIST K:\PRIVATE\M4ROOT\CLIP\NUL GOTO NOPATH
    copy /Y "K:\PRIVATE\M4ROOT\CLIP\*.mp4" "C:\import\film"
:: Rename all files in import folder, here mov and mp4    
    u:\script\exiftool.exe -ext mov -ext mp4 -m "-FileName<CreateDate" -d "%%Y-%%m-%%dT%%H%%M%%S%%%%-c.%%%%le" c:\import\film

:: Eject media from cardreader, -f=force, -L= loop until success, -A=, -W= wait 1000ms before end the program
C:\USBDLM\EjectMedia K: -f -L -A -W:1000

:: Start FastRawViewer for culling
c:
"C:\Program Files\LibRaw\FastRawViewer\FastRawViewer.exe"

:: After exit of FastRawViewer copy and move files
copy /Y "C:\import\*arw" "F:\rawcopy"
move /Y "C:\import\*jpg" "C:\import\jpg"
timeout 5
exit

:NOPATH
ECHO Nothing to copy
timeout 5

Link to post
Share on other sites

Thanks for that, timde.  I have 4 cards, as I use the A7s2 to make long-form documentaries and sometimes have very busy days.

 

Sorry to be a bit thick, but are you suggesting I make a folder with a unique name on each of the cards; download the folders to a hard drive when they are full or a session has finished; delete the files from the folder on the card; empty the trash; then start again?

 

Is that it? Is it possible to delete the files but not the folder, or do I have to reinstate the folder for the next shoot?

 

At the moment I download the files; batch rename them; then format the card and start again. The problem with this is I am not well-organised enough to give each folder a sequential number so I don't have any chronological order.

 

Canon is sooooooo much simpler!

 

 

It is in the menu, last pages somewhere, create folder and select folder. RTM.

 

It is limited, but sufficient if you really need such a solution. Obviously the Canon way is better ...

Link to post
Share on other sites

If you are on a Windows machine you could do some automatic actions when inserting a card to the card reader.

Here is the workflow that's works for me (you need a little bit of computer skills, very basic)

 

I use two freewares from http://www.uwe-sieber.de/usbdlm_e.html.

USB Driveletter Manager and EjectMedia.

 

For renamning the photos as well as movies I use another freeware, exiftool.

http://www.sno.phy.queensu.ca/~phil/exiftool/

 

First I make sure that the SD card slot on the Lexar Cardreader always will be mapped as K:

I use the USBDLM and have these settings in the ini file.

.......................................

[DriveLetters60]

;Lexar 5slot, SD card slot

DeviceId6=000000027677&1

Letter=K

 

[OnArrival]

Letter=K

open="U:\script\move_raw_2_import.cmd"

 ......................................

 First the mapping and then when a card is inserted, start a script

 

 So here is what I do in the script (it's an easy batch script)

 

:: Check for images on media and copy files from cardreader to folder on harddrive

IF NOT EXIST K:\DCIM\100MSDCF\NUL GOTO MOVIE

    copy /Y "K:\DCIM\100MSDCF\*.*" "C:\import"

:: Rename all files in import folder, here just jpg and raw

    u:\script\exiftool.exe -m "-FileName<DateTimeOriginal" -d "%%Y-%%m-%%dT%%H%%M%%S%%%%-c.%%%%le" c:\import

 

:MOVIE

:: Check for movies an media and copy files from cardreader to folder on harddrive

IF NOT EXIST K:\PRIVATE\M4ROOT\CLIP\NUL GOTO NOPATH

    copy /Y "K:\PRIVATE\M4ROOT\CLIP\*.mp4" "C:\import\film"

:: Rename all files in import folder, here mov and mp4    

    u:\script\exiftool.exe -ext mov -ext mp4 -m "-FileName<CreateDate" -d "%%Y-%%m-%%dT%%H%%M%%S%%%%-c.%%%%le" c:\import\film

 

:: Eject media from cardreader, -f=force, -L= loop until success, -A=, -W= wait 1000ms before end the program

C:\USBDLM\EjectMedia K: -f -L -A -W:1000

 

:: Start FastRawViewer for culling

c:

"C:\Program Files\LibRaw\FastRawViewer\FastRawViewer.exe"

 

:: After exit of FastRawViewer copy and move files

copy /Y "C:\import\*arw" "F:\rawcopy"

move /Y "C:\import\*jpg" "C:\import\jpg"

timeout 5

exit

 

:NOPATH

ECHO Nothing to copy

timeout 5

 

Old swede, thanks for your detailed reply.

Sadly, I'm on Mac - I should have mentioned this!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Similar Content

    • By Rt84
      Hey everyone!
      Just wondering if anyone can give me some recommendations for settings on the sony A7 mk1?. Going to shoot mostly stills in raw so not too worried about picture profiles just more setup info or any other pro tips.
      Also I've heard some bad things about bricking when doing firmware updates, is the newest firmware update any better and worth doing if it's out of date, I think 2016, 4.2 or 4.3 (something like that) is the newest version, also heard you get a better video codec with the update??...
       
      Thanks ?
    • By Ibrahim Sajid
      I have a Sony A7ii Camera and recently I formatted a new memory card on my camera and the battery was around 40%. During the format process, the camera turned off and when I tried restarting it again, it won't show any firmware in the camera and would just flicker once with the live view display and then go black. 
      I have been trying to solve this problem and have no success till now. Please help out if any of you have any idea how to get this fixed. 
       
    • By Vinesh
      Hi all,
      Sony offers a Wifi enabled remote view/control which I find myself often using, due to what I shoot. However, the ImageEdge / Sony Alpha (A6400) camera firmware combination turns out to be very unreliable (not only to me, but to many others I read).
      Often when my phone screen goes off, I will have to go Back in the camera menu, find the remote menu item, reveal the QR and rescan, otherwise it won't work. I have hit the 'report issue' function each time (which triggers a flimsy error code in the error report (ironically) and I keep hoping this will finally be fixed someday. For a modern camera in this class, we should expect this to work.
      Additionally, I also tried ImageEdge for desktop to wirelessly transfer / preview data during shoots. After many restarts, reconnects, reinstalls it doesn't find my A6400 at all. (this would make a massive difference opposed to cable or worse; take my camera off my balanced gimbal and remove the SD card because sometimes the USB connection doesn't respond).  

      In other words; Sony has is lacking big time when it comes to modern day wireless features (mobile monitor / transfer, desktop monitor / transfer). Does anyone know if there is better 3rd party software available with the capability to do this with a SonyA6400. Or; if Sony is rolling out actual fixes on this soon?
       
      Thanks!
      - Vinesh

       
       
       
    • By jdvoracek
      MacOS users BEWARE!!  I just bricked an A7RII ILCE-7RM2 trying to update from 4.0 to 4.01 using my MacBook Pro with Catalina 10.15.3 VERY CAREFULLY following Sony's instructions.  I had updated this camera with this computer but an earlier OS successfully in the past.  About 1/3 way done, the camera just disconnected from the computer (volume disappeared from desktop), the little red light would not go out, and the camera would not reconnect.  I tried pulling the battery.  I read where some folks had to run the update more than once, but I couldn't run it again on the Mac because the Mac would not mount the camera as a mass storage volume.  The reason I am not really upset is my wife has a desktop PC, and even in this messed up state, the camera responded to the Windows updater and is updated and running.
    • By erikdepooter
      I own both an A6500 camera and also a NEX-3N for backup. Because I recently bought a new primelens I had to update the firmware on both cameras.  With the A6500 there was not a single problem. But attempting the same procedure with my NEX-3N resulted in an error message. See attachment. Downloading the photo's by means of USB (Mass stoarage) is not a problem, so there must be a connection between camera and PC.
      Does anyone recognize this and perhaps know a solution? For instance by means of use of the programfile on my SD-memorycard?

  • Topics

×
×
  • Create New...