Jump to content

Sony A7R4a touch focus stopped working (But focus tracking works?)

Recommended Posts

I have touch-focus set to on and although I can touch the screen and the curser meets my finger/follows it, it does not focus.

It did the last time I used it because I remembered using it for composing by touch.

I am flummoxed, the only thing that I have changed was a firmware update and last week I tried to connect my P30 pro to the camera (Which was when I realised the touch focus had stopped?) so not sure what caused it.

The camera is in mint condition, I have had it since new (just over a year ago) I am the only user and can say that it has been looked after very well, it's has had no knocks or any damage.


The touch-tracking works and will focus at any point where I touch the screen while continuously tracking that point, and yes, I have thought about touch-tracking, but it's slower and a bit clumpy compared to touch focus which I much prefer using. I tap away at the screen in touch mode, but it won't focus, it follows the finger where ever you move it, but no focus.

I reset the camera to its factory defaults, but still no touch focus?


Any help much appreciated.



Edited by The Naked Ape
Link to post
Share on other sites

In Stills mode, the touch focus function only selects the focus point. Focus is achieved by pressing the shutter (or button you assigned to focus).

It works in video mode though.

Welcome, dear visitor! As registered member you'd see an image here…

Simply register for free here – We are always happy to welcome new members!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...