Jump to content

Slow Loading of Thumbnails in Premiere Pro & Davinci Resolve


Recommended Posts

For years I've been thinking that this is a Software issue that Premiere & Davinci have not been able to resolve. "BUT IT'S NOT"

If anyone at Sony is watching this please fix this. I primarily use a Sony A7III for all my video shoot and I rely on that camera for my survival. The one thing that has been driving me nuts is the fact that the thumbnails take forever to load. And I noticed that this is not a Premiere or Davinci thing because I just recently had got my hands on some Blackmagic footage as well as some canon footage and those files thumbnails loaded with the blink of an eye. So whatever the issue is with the files if it can be fixed with a firmware update then please do so. Sometime when I scroll too much while the thumbnails are still loading the program will simply crash on me while that never happened on the Blackmagic footage. So PLEASE PLEASE PLEASE Fix it.
If anyone else notices this issue then add up to this post.. Thank You

Edited by Akrist Shakya
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...