Jump to content

Sony a7rii not started

Recommended Posts

  • 1 month later...

 Hello Michal, i have the same problem, i have try different fully charged batteries, and still the same funny thing is one time i was able to get to the USB Mode Mass Storage page by connecting the camera to my computer with the usb cable and running the firmware update, i managed to run the firmware update and right after it was done updating it went back to the black screen like the video you uploaded.

Did you solved the problem? 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...