Jump to content

A7RIII Firmware Update Fails (Could not find the camera for this update)

Recommended Posts

Advertisement (gone after registration)

I really love this camera but I am currently at my wit's end with this firmware update - I am trying to do a simple update to the latest firmware but despite the fact that my camera otherwise connects perfectly to my PC (remote shooting, Windows showing the camera folder etc. etc.), the update software refuses to find the camera.

I have tried the following:

  • Ensured that I'm using the USB-C cable that came with the camera
  • Made sure that the camera is in mass storage mode
  • Restarted my PC
  • Restarted the camera and took the battery out for a while
  • Followed the sequence described on the firmware update page to the tee
  • Tried it on a different laptop running Windows 7 with exactly the same result
  • Tried with and without a lens attached
  • Made sure that the cable is connected directly to the PC - that it's not going through a USB hub
  • Closed all applications, disabled firewall

When I plug the camera in via the usb c cable, Windows reacts by showing a new device is connected, and the camera also shows that it is successfully connected via usb, then why does the software update application fail to find the camera? I had no issues with Imaging Edge connecting with the camera either. I also had no issue updating the A7SIII either.

I'm running an up to date Windows 10 that surpasses all requirements listed on the firmware update page and the camera is currently on v1.0.0 (the lowest/oldest version I think).

I've heard some say that one has to update from V1.x to V2.x, then only to V3.x, but I can not find any versions under V3 either, does anyone have a link for V2?

Has anyone encountered this before or has any advice for what I can try next? Any help will be greatly appreciated!

Link to post
Share on other sites

Posted (edited)

I think I found the answer for those who might be facing the same "issue"!

Apparently there is a new version of the A7RIII out with product name ILCE-7RM3A vs. the older ILCE-7RM3 (note the A vs. no A at the end). I see the ILCE-7RM3A product code under my camera - I recently bought it. I never knew about this and kept landing on the ILCE-7RM3 firmware download page, little did I know there is a separate firmware download page for ILCE-7RM3A, but his page does not have any new firmware currently. Perhaps ILCE-7RM3A already has all updates from the previous ILCE-7RM3 camera firmware??

This is quite interesting. Apparently Sony made some minor improvements in  ILCE-7RM3A over the older version, most notably a higher res back LCD screen and the Sony label removed at the bottom of the back screen.

ILCE-7RM3A firmware download page:


ILCE-7RM3 firmware download page:


The same seems to apply to the A7RIV too.

An interesting read on the topic:https://www.dpreview.com/news/8756997638/sony-quietly-updates-the-a7r-iii-a7r-iv-with-improved-lcd-displays

Edited by RooiValk
Link to post
Share on other sites

  • 1 month later...
  • 3 weeks later...

I bought a Sony A7RIIIA because of the good sale price, never hurts to have an extra body. I pulled my hair out for about an hour trying to get my camera to get recognized by the Sony firmware updater for the Sony A7RIII firmware. After a short google search I found this. Thanks for the information! This seems to be the case for me too!


Link to post
Share on other sites

  • 2 weeks later...

Advertisement (gone after registration)


I can't find the ILCE-7RM3A firmware download on the camera link:


Was it removed or something? I tried with the 7RM3 (no A) updater but without success - the "Could not find the camera for this update" message appears.

Can anyone share link to the updater file?


Link to post
Share on other sites

I came across an interesting reply on a board stating that : it is normal for a brand new camera A7R3a to have its firmware 1.00 because it's new :) and there's nothing to update.

Hope it helps


Edited by SLAZT
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Posts

    • Also consider the new A7iv. It has a lot of the A9ii except the 20 fps silent shutter. If you really value that, get the A9ii. Otherwise the A7iv may be just as nice for half the price.
    • Hi everyone, I’ve been using my A7iii for about 3 years now and overall I’m pretty happy with it. I find myself wanting to upgrade to a newer model namely for: a better menu, EVF, ergonomics and better auto focusing. I don’t have a set budget, I want to buy the right camera for my needs. The type of photography I primarily do is travel/documentary. Video is nice to have but not that important to me. I shoot some landscapes but this isn’t my primary focus. Occasionally I will crop but that isn’t very often. A fast shutter speed is nice to have in some of the environments I shot in. Low light performance is very important to me along with eye auto focus. Obviously everyone is lusting after the A1 right now and I have to admit, I’m tempted. For my uses I think 50 megapixels is too much. I however I’m not entirely sure as I’ve never used a high megapixel camera. The camera that seems to check all of the boxes is the A9ii.    I may have answered my own question but I’m interested to hear everyone’s opinion.    Thanks
    • I paired a JJC BTR-S1 remote with my Sony A1. I want to unpair it but can't figure can't how to do that. Can someone help me? TIA.
  • Topics

  • Create New...