Jump to content

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By Iceman382
      Sony SLT-A65V
       
      Camera worked fine one day and then it would not turn on. 
      The only thing it does is 3 red slow flashes followed by 6 red fast flashes, then repeats.
      Makes no noises and nothing on LCD screen.  Only flashing light sequence.
       
      Normal nature shooting at temperature about 70 degrees.  Normal to average humidity.
      No error messages. No recent changes.  No recent firmware updates.
       
      Tried new batteries... still would not turn on.   Only red light flashing.  
       I have tried all recommended ways to do a hard reset and nothing works.
      Sony was no help either...try reset and send it in garbage.
       Any ideas/help would be greatly appreciated.
       Thanks.
    • By eggwah123
      Just bought the lens. Test it and very happy until I noticed dark upper corners, worse in the left. It only show up at small aperture (eg F11 F16 F22)and focus at infinity. The smaller the aperture the worse.
      its worst in my A7II. Less noticeable in the A7RII. No hood or filter attached.
      Picture shown is taken by A7II:
      any idea what’s the cause? Please help. Can see the dark corner in EVF while composing and focusing 
      All camera have updated firmware.
       

      Hello guest! Please register or sign in to view the hidden content.
      Hello guest! Please register or sign in to view the hidden content.
    • By imboredx9999
      Hello,
      I just got used A7riii and the touchscreen does not work. I have tried updating the firmware, resetting the camera multiple times, changing the setting that has to do with autofocus (yes I'm aware that you have to turn this function on, I've turned it on and off so many times already) I'm not sure what I'm missing. The touchscreen is just unresponsive. I've done everything short of sacrificing a goat. Has anyone else run into this issue before? The previous owner says that they never used the touchscreen so they were not aware of it. Please help me figure it out. It cost a lot of money.
      Thanks!
    • By Mr Desk POP
      Hi All!
      My name is Josh and I'm a previous Canon owner. I used Canon cameras quite a bit (Canon T2i, 5D Mark II, 6D, 80D, 6D II, 5D Mark IV, and EOS R). I'm a hybrid shooter and I thought the camera to rule them all would have been the EOS R5, so I preordered. I read reviews, I watched test videos, I even watched Peter McKinnon to convince myself that this was it. This was the answer to all of my camerawomen woes (mainly 4:2:2 10 Bit and 4K 120p).
      Then I thought about it, and thought about it, watched some more Peter McKinnon and thought about it. I came to the conclusion that overheating, recording limits, and overall Canon's response to what people were asking was enough for me to leave. I decided to switch to Sony.
      But not just any Sony, I decided to preorder THE A7s III.
      I sold old, outdated, new but never used gear on Craigslist. Not to mention all of my beautiful glass.
      Now I'm here...
      Waiting...
      By the door.
      Is it September 24th yet?
    • By Mr. Camera
      I am getting tired when I think about my camera if it gets stollen. I wish if sony now start to think about securing our expensive cameras by adding builtin gps tracker in new cameras or battery grips for the late cameras. 
  • Topics

×
×
  • Create New...