Jump to content

Recommended Posts

Hi All!

My name is Josh and I'm a previous Canon owner. I used Canon cameras quite a bit (Canon T2i, 5D Mark II, 6D, 80D, 6D II, 5D Mark IV, and EOS R). I'm a hybrid shooter and I thought the camera to rule them all would have been the EOS R5, so I preordered. I read reviews, I watched test videos, I even watched Peter McKinnon to convince myself that this was it. This was the answer to all of my camerawomen woes (mainly 4:2:2 10 Bit and 4K 120p).

Then I thought about it, and thought about it, watched some more Peter McKinnon and thought about it. I came to the conclusion that overheating, recording limits, and overall Canon's response to what people were asking was enough for me to leave. I decided to switch to Sony.

But not just any Sony, I decided to preorder THE A7s III.

I sold old, outdated, new but never used gear on Craigslist. Not to mention all of my beautiful glass.

Now I'm here...

Waiting...

By the door.

Is it September 24th yet?

Link to post
Share on other sites

Welcome to the club. Cameras should be shipping Sept 24th yes but earliest pre-orders might be satisfied first, unless there's enough for everyone which would be great. That is quiet a change you are going through, good news is that with a7SIII Sony is implementing a new touch menu so at least in this department you will feel closer to home. Hope 12mp is enough for your photography needs, & mine ☺️

Link to post
Share on other sites
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Similar Content

    • By Sam29
      Hello,
      My Sony 70-200 2.8 GM lens not communicating with my body. im getting dash in aperture, lens not focusing at all.
      I tested this lens on multiple sony bodies. 
      did anyone had this issue ?  
    • By empcreative
      After not using my a7siii for about a day, I picked it up to shoot something and it would not power on. 
      There were no new changes to settings nor any attempts to update firmware. Battery was fully charged.
      Issue:
      Right away when putting in a fresh battery (OEM Sony battery), the access lamp will flash. then flash every 3 seconds. Camera doesn't respond when trying to switch on. 
      Attempted efforts to resolve the issue:
      1. I've tried removing and swapping different SD cards, Sony Batteries, and Sony Lenses.
      2. I've also tried power cycling the camera by removing the battery for a min, turning it on, holding the shutter down for 30 sec, then powering off, and reinstalling the battery.
      3. I've tried connecting the camera directly to my computer, nothing.
      4. Plugging the camera into the wall to see if it'll charge the battery, no. Charge lamp doesn't even turn on.
      Can't find anyone else with these issues. Feels like the camera literally bricked itself somehow.  
      Link to dropbox for a video to show the issue. 
      https://www.dropbox.com/s/m1xohg52twmcz3k/IMG_0620.MOV?dl=0
    • By Iceman382
      Sony SLT-A65V
       
      Camera worked fine one day and then it would not turn on. 
      The only thing it does is 3 red slow flashes followed by 6 red fast flashes, then repeats.
      Makes no noises and nothing on LCD screen.  Only flashing light sequence.
       
      Normal nature shooting at temperature about 70 degrees.  Normal to average humidity.
      No error messages. No recent changes.  No recent firmware updates.
       
      Tried new batteries... still would not turn on.   Only red light flashing.  
       I have tried all recommended ways to do a hard reset and nothing works.
      Sony was no help either...try reset and send it in garbage.
       Any ideas/help would be greatly appreciated.
       Thanks.
    • By Dang10
      Focus is great and quick, but as soon as I go to video the focus stays sharp but keeps running even if the subject doesn’t move. Here’s a link I shot (couldn’t attach the video here) https://imgur.com/a/z4FwBrb
    • By Makeev
      Sony told about memory cards supported by the α7S III (ILCE-7SM3) camera. But what about the SF-G series? My Sony cards have no V30/V60/V90 speed tags. No one from the company answers my questions on Twitter. Apparently, another Sony story is repeating itself. The story of a company pushing customers to buy new, new, new...

  • Topics

×
×
  • Create New...