Jump to content

A6000 Focus Stuck


Recommended Posts

Advertisement (gone after registration)

Greetings,

I've had my Sony A6000 for at least 5 years, but for the last year or so, I've been randomly facing this issue where my focus appears to be continuously partially pressed. What that does is I am not able to do anything (click on anything else) other than clicking the shutter button to take pictures. Here's a picture of what it looks like

sony.jpg.5bff72923e2b068f2edd7eda5d3605e0.jpg

As you can see, my camera is just on, but it behaves as if I partially have the shutter button pressed. In the past, i've assumed that maybe my button is partially pressed, and I try to pull it awkwardly, sometime it works, sometimes it doesn't. This has become more of a problem recently and has made my camera almost unusable. Has anyone else faced this issue?

Link to post
Share on other sites

Haven't faced this issue but I guess it's due to wear on the shutter button. A renowned camera store should be able to fix it but might be cheaper to just buy another used a6000.

A partial fix might be to put the camera in AF-C instead of AF-S: at least it will refocus when you move the camera or subject. Use zone focussing to determine where you want to focus if it doesn't lock onto your desired subject.

Link to post
Share on other sites

Thank you Pieter for your response.

I called Sony Customer support and the gentleman was very helpful. You were right that this is probably a hardware issue and needs to be sent to a service center/shop to be fixed. However, after suggestions from the customer service agent,  I got around the problem by turning off AF on the shutter button and using the AEL button to AutoFocus ( I achieved this using "Custom Key Settings". It's a minor inconvenience but should give me more mileage out of my camera for the time being. I might face some other issues, since the original hardware issue of the shutter button "partially pressed" is still there, so it might lead to other issues. 

 I'll update this thread if this doesn't work out in the long run.

Link to post
Share on other sites

  • 1 year later...

hi, i have same condition as this. the AF are stuck and also the rest button not working when the AF stuck. so i replug the battery and change the autofocus into DMF for temporary setup till i can pay the sparepart for this. the autofocus still fine but it goes by press dial button for focusing *the sony guy tell me that i have to change the shutter due some error hardware which i think that not the problem as i still can take photo from ithe camera itself

Edited by mako
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Similar Content

    • By mirperei
      Hello everyone! 
      so, after much searching for an answer I guess I need to show (to someone who understands what I’m talking about) examples of my problem. 
      the first images were shot with the kit lens (16-50) or the 18-200 OSS SONY lens (great lens!) a few years ago and had no editing. 
      they were amazing! I could see them razor sharp in the PC and I’ve printed quite a lot of them (biz sizes as well). 
      but lately (end of last year, and 2020) I’ve been seeing that the camera has much more difficulty to focus (it takes wayyy more time to focus) and most of the times doesn’t even focus at all. 
      I used mainly P or SCN modes but now that I got a bit more to learn about photography I’ve been trying to get into M mode. And also bought a prime lens (Sigma 30mm f1.4). and the problem persists! Even with the sigma lens (which has the reputation of being perfect sharp) I see lots of noise and just not a good sharp image, not in the viewfinder and even less in my new Mac... 
      I don’t know what to do. Wanted to buy a new one but I really loved my a6000 and don’t want to just dismiss it because it’s “outdated”. 
       
      ah! I’ve upgraded the firmware and have initialised it many times... still, some photos are ok but not great and most of them do not focus at all! 
       
      Suggestions? How can I be sure it’s defective?
      thanks!!! 
       
      Dropbox link to photo comparison: https://www.dropbox.com/sh/u6mhu47ltmoecic/AADDNuVFUOUX_60RLm-xIetla?dl=0
    • By Lennox Horn
      I have 2 issues using these functions for the first time on the Sony A6000 :
      When I shoot to register a face for the first time I continually get an error 'Cannot Register…Shoot Again'  When I set the chosen Smile shutter setting  no green frame appears to frame the face and trip the shutter Is there specific settings I that the camera should have before activating these two functions
      Thanks in advance of any pointers/advice to resolve this
      L
    • By mario7
      Hi!
      Several months ago some strange things started happening with my a6000.
      For example when I'm previewing my photos, the camera jumps to the shooting mode by itself. Or when I am manual focusing with the magnifier, it disappears. It's like I'm pressing the shutter button. But it's not only that. When I'm recording video, it will suddenly stop recording, like I've pressed the recording button (sometimes after 10 sec, sometimes after a minute or two). It's like pressing different buttons by itself. Sometimes it's changing the shooting mode for a couple of seconds.
      I don't have any idea what's happening.
      Can someone help me? Thanks in advance!
    • By hcrpaiva
      Something very strange happened. I was shotting when the camera stopped recognize image, just showing a white screen.
      I tried to change the iso, the shutter speed and the aperture, but it didn't interfere with the image. Always white.
      I also tried to format the card, clean the sensor, change lenses and batteries, reset the settings, but nothing worked.
       
      Anyone have any idea what to do?
      thanks
       
      ps: I found strange the mark on the left side of the curtain. I do not know if it has something to do with the problem.


  • Topics

  • Posts

    • Also consider the new A7iv. It has a lot of the A9ii except the 20 fps silent shutter. If you really value that, get the A9ii. Otherwise the A7iv may be just as nice for half the price.
    • Hi everyone, I’ve been using my A7iii for about 3 years now and overall I’m pretty happy with it. I find myself wanting to upgrade to a newer model namely for: a better menu, EVF, ergonomics and better auto focusing. I don’t have a set budget, I want to buy the right camera for my needs. The type of photography I primarily do is travel/documentary. Video is nice to have but not that important to me. I shoot some landscapes but this isn’t my primary focus. Occasionally I will crop but that isn’t very often. A fast shutter speed is nice to have in some of the environments I shot in. Low light performance is very important to me along with eye auto focus. Obviously everyone is lusting after the A1 right now and I have to admit, I’m tempted. For my uses I think 50 megapixels is too much. I however I’m not entirely sure as I’ve never used a high megapixel camera. The camera that seems to check all of the boxes is the A9ii.    I may have answered my own question but I’m interested to hear everyone’s opinion.    Thanks
    • I paired a JJC BTR-S1 remote with my Sony A1. I want to unpair it but can't figure can't how to do that. Can someone help me? TIA.
  • Topics

×
×
  • Create New...