Jump to content
Sign in to follow this  
Del

NEW Sony a9 adopter

Recommended Posts

Hi 

I have just placed an order for an a9 today having been a Nikon users for 4 decades. A friend let me borrow his a9 a few weeks ago to take photos for my sons American football team (based in the UK) and I was blown away it’s so fast

Went in to local shop in Glasgow to try it and have ordered that and a lens arriving next week and traded in all my Nikon gear.

I look forward to learning a new system and updating you with my experience and in all likelihood asking questions

 

 

 

 

  

 

 

 

 

 

Share this post


Link to post
Share on other sites

I too am a convert from Nikon and have zero regrets. The a9 is crazy great, and even better with the new Firmware 5.0. Now is the time to catch up on all of Mark Galer (markgaler.com) YouTube videos to get the most out of the camera.  Welcome!

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Similar Content

    • By us40489
      I can't seem to get the new Sony RMT-P1BT to connect with the A9 (under Software Ver 5.0). No problem with my A7R3 (under Software version 3.0) but no way to do this with the A9. When trying to pair the menu always offers "Make Bluetooth connection via Imaging Edge Mobile on Smartphone" whereas on the A7R3 it says. "Perform pairing on the connected device" and it then offers the painting with the remote. Any tips available?
    • By AlexClass
      Hi,
      has anyone has any slowing down issues with their a9?
      When I use the aperture and time dial the responses are so bad that it nearly takes up to 2/3 seconds to change.
      Sometimes lags terribly as well. If I switch off, the camera actually takes up to 5 seconds to go off.
      The AF is slow as well. Tried multiple, lenses, cards, batteries and still have the same issue.
      Apparently once it's been on for a while, like 5 or 10 minutes, hanging down on my shoulder it gets worse.
      As soon as I switch it off and back on again, the issue is gone for a few minutes then gets bad again.
      Anyone have any ideas?
      Its hosting the latest firmware to this date.
      Many thanks.
      Alex.
    • By Chuck_diesel
      I started with a Minolta and then switched to Canon. I have a nice line of Canon lenses, to include a Canon 400 f2.8 and a 600 f4, which are fantastic. I am considering switching from a 5D3 to an A9, but I am reading that the A9 will not shoot at 20fps when using a non-native lens. Can someone explain why this is the case seeing that a lens is just something that the camera sees through? Unless this is just a tactic that Sony is using to force sports photogs to use their lenses, instead of the ones they have already spent 10's of thousands on?
×
×
  • Create New...